JAVA kullanmayın, kullandırmayın. Eski ise asla!

1 post / 0 new
JAVA kullanmayın, kullandırmayın. Eski ise asla!

Yeni trendler ve Türkiye gerçekleri.

Takip edenler bilir çok kısa bir süre önce Twitter'e bir saldırı oldu.
250.000 den fazla twitter kullanıcısının bilgileri hackerlerin eline geçti.
Çeşitli kaynaklarda sorunun JAVA'dan kaynaklandığı yazılıyor ve bilgisayar sistemlerinden JAVA nasıl kaldırılır, bu anlatılıyor.

"Twitter kullanıcılarının alabileceği önlemler
Twitter hesabınız bu saldırıdan etkilenmemiş olsa bile bazı basit önlemleri almanızda fayda var:
- Twitter şifrenizi yenileyin, şifreniz basit olmasın
- Küçük-büyük harf, rakam ve semboller kullanarak şifrenizi güçlendirin
- Twitter için kullandığınız şifreyi başka hesaplarınızda kullanmayın
- İnternet tarayıcınızda Java'yı çalıştırmayın
İnternet tarayıcınızda Java'yı iptal etmek için
- Firefox: Araçlar (Tools) kısmından Eklentileri (Add-ons) seçin ve tüm Java eklentilerini iptal edin
- Safari: Seçenekler (Preferences) kısmından Güvenlik (Security) seçin ve Java'yı aktive et (Enable Java) seçeneğini iptal edin.
- Chrome: Tarayıcınıza Chrome://Plugins yazın ve tüm Java eklentilerini iptal edin
- Internet Explorer: Windows kontrol panelinden Java uygulamasını iptal edin (Detaylı bilgi için: http://www.java.com/en/download/help/disable_browser.xml) "

Bu noktada Türkiye gerçeklerine dönüş yapıyoruz.
https://ebeyanname.gib.gov.tr/download.html
Linkinde görebileceğiniz gibi şirketler, muhasebeciler JAVA'ya mahkum edilmiş durumda. Üstelik bu gibi programlar birilerine bir sürü para ödenerek yaptırılmasına rağmen genelde işin geleceği hiç düşünülmez. En ufak bir java güncellemesinde program çalışmaz hale gelir -OpenOffice daha ileri bir javayı kuruyordu ve program devreden çıkıyordu-. Programcılara ileriye dönük olarak gelişmelere ayak uydurma zorunluluğu ya getirilmemiştir ya da umursanmamıştır. Sonuçta bu programı yazan kişilerin izi bile ortada olmayabilir. Ortadan kaldırılmaya çalışılan bu sürümlere harcanan onca para bir yana muhasebeci ve şirketlerin beyanname sistemi de büyük bir tehdit altında şu anda.
JAVA'nın kendi resmi sitesinde bile,
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-arc...
şu uyarı yer alıyor.
"WARNING: These older versions of the JRE and JDK are provided to help developers debug issues in older systems. They are not updated with the latest security patches and are not recommended for use in production."
Türkçesi: UYARI: JRE ve JDK'nın bu eski sürümleri programcılara eski sistemlerdeki hataları ayıklayabilmeleri için sunulmuştur. En son güvenlik güncelleştirmeleri bu dosyalara uygulanmamıştır ve gerçek hayat uygulamalarında kullanılmamaları gerekmektedir.

Neticede sahibinin bile kullanmayın dediği bir şey Türk kullanıcısına kullandırılıyor.
Epey uzun oldu kusura bakmayın ama konu önemliydi.